Skip to main content

Error 521: Web server is down in plesk with cloudflare

Symptoms

When visiting the website, it fails to load with error 521. The error occurs because the origin web server refused the connection from CloudFlare
CloudFlare is used
Website uses Nginx as a reverse-proxy;

Cause

CloudFlare IP addresses were blocked by nginx because of outdated contents of /etc/nginx/conf.d/cloudflare.conf.
/etc/nginx/conf.d/cloudflare.conf contains old CloudFlare IP addresses list.

Solution

Make sure that you're not blocking CloudFlare IPs in .htaccess, iptables, or your firewall.
Make sure that you're operating off of the most recent versions of Bad Behavior or mod_security. You want to ensure that mod_security's core rules aren't blocking CloudFlare requests;
If you are running custom Apache modules, such as mod_antiloris and mod_reqtimeout, disable and unload the modules. These modules will block any time an IP that connects more than 22 times. Since all connections are now coming from a CloudFlare IP, you will definitely hit the limit causing the error page. As soon as you unload the module, the issue will disappear.
Make sure that /etc/nginx/conf.d/cloudflare.conf is up to date and contains all IP addresses found here: https://www.cloudflare.com/ips;

Make sure your provider doesn't rate limiting or blocking IP requests from the CloudFlare IPs and ask them to whitelist the IP addresses found here: https://www.cloudflare.com/ips;
If the issue persists, please visit CloudFlare article regarding this issue.

Comments

  1. This comment has been removed by a blog administrator.

    ReplyDelete
  2. This comment has been removed by a blog administrator.

    ReplyDelete
  3. This comment has been removed by a blog administrator.

    ReplyDelete
  4. This comment has been removed by a blog administrator.

    ReplyDelete
  5. host that implements PHP web hosting should succeed fully processed. An advantage is to be noted. PHP hosting has a plenty of versions for programming languages. There are numerous constraints that one has to face when he chooses for PHP web hosting. There are variable types of php web hosting platforms and hosting packages with new technologies. php web hosting is its compatibility and support for different types of databases. https://hostinglelo.in/

    ReplyDelete

Post a Comment

Popular posts from this blog

How to Speedup your WordPress site with Amazon CloudFront.

Introduction A WordPress performance is quite excellent . The number of WordPress plugins to handle performance is such evidence. But the easiest way to improve your user experience is to accelerate the entire WordPress website using CloudFront. This will help you not only improve site response time reduces the necessary infrastructure, reducing the load on the Web server, so you can reduce the total cost of the infrastructure works WordPress. CloudFront is actually a site can greatly help your site to respond to unexpected load when gained popularity. Today this post is to clarify the method of providing a reasonable standard configuration on the WordPress website or blog. How does CloudFront help? Amazon CloudFront is to improve the user's experience accessing the Web site in several ways: 1.  Anycast DNS is to ensure that customers are routed to the nearest edge location. 2.  The cached content is available to users at the edge positi...

Serverpilot : Easiest way to Setup | Manage | Secure your PHP Website with Amazon Cloud EC2 Servers

ServerPilot is the easiest way to run PHP applications such as Laravel, Yii, Coordinator, Magento, WordPress on Amazon EC2 servers to keep your server secure. If you're not a sysadmin, you should use a developer-friendly environment  with ServerPilot. 1 st  Setup EC2 Instance. 2 nd  Connect EC2 Server to ServerPilot Setup EC2 Instance L og in to the  AWS Management Console .   Once logged in, click on EC2 . Then click Instances in the left menu and then click Instance Launch button. The instance creation tool starts. Now, select Ubuntu Server 16.04 LTS 64-bit or Ubuntu Server 18.04 LTS 64-bit as your Amazon Machine Image (AMI). After Select AMI Please check My blog in 2 nd  point Configure your instance  from Step 2 to S tep 6. Click Here...... Configure the Security Group You can see the name of the security group for your instance in the instance details screenshot above (in this case, it's "laun...

YouTube channels data migration in new google account

Introduction : YouTube all data (Channels, Videos, Likes, subscribes) migration from one google account to another google account. Please follow below steps to migration YouTube data. For example your source email id is source@gmail.com  and target email id is target@gmail.com . We need to move all source@gmail.com ’s YouTube data to target@gmail.com . Step 1 . Login in source@gmail.com  account and open YouTube settings Step 2 .   Now that you have to create a Brand Account, For that See all my channels or create a new channel   ( Note :- If you haven’t any Channel so click on Create a new channel   Then back on setting and follow Setp 2. ) After Click on Create a new channel . You will be move on for create new Brand Account.   Step 3.  You have to add your Brand Account name here. Step 4.  Open YouTube setting for source@gmail.com     and click the Advanced   Step 5 . Now you need to move your YouTube all data in new created...